// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(زیر\s?زمین|خانه|آپارتمان|زمین)").unwrap();
let string = "زیر زمین ۱۳۰ متری تک خواب نقاشی شده وتمیز بلوار فلسطین
شهرک فرهنگیان ۲م رهن با ۸۵۰ت
فقط خانواده
املاک عباسی ۳۸۲۰۱۳۱۳";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}