package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(زیر\s?زمین|خانه|آپارتمان|زمین)`)
var str = `زیر زمین ۱۳۰ متری تک خواب نقاشی شده وتمیز بلوار فلسطین
شهرک فرهنگیان ۲م رهن با ۸۵۰ت
فقط خانواده
املاک عباسی ۳۸۲۰۱۳۱۳`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}