use strict;
my $str = '1.2.3.4
91.9.9.111
0.0.0.0
121.211.233.251
255.255.255.255
121.255.255.256
256.255.255.2
999.999.999.999
';
my $regex = qr/^(2[0-4]\d|25[0-5]|1?\d?\d)(?:\.(?1)){3}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}