#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(2[0-4]\d|25[0-5]|1?\d?\d)(?:\.(?1)){3}$"
Local $sString = "1.2.3.4" & @CRLF & _
"91.9.9.111" & @CRLF & _
"0.0.0.0" & @CRLF & _
"121.211.233.251" & @CRLF & _
"255.255.255.255" & @CRLF & _
"" & @CRLF & _
"121.255.255.256" & @CRLF & _
"256.255.255.2" & @CRLF & _
"999.999.999.999" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")