# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?<type>build|chore|ci|docs|feat|fix|perf|refactor|revert|style|test|¯\\_\(ツ\)_\/¯)(?<scope>\(\w+\)?((?=:\s)|(?=!:\s)))?(?<breaking>!)?(?<subject>:\s.*)?|^(?<merge>Merge \w+)"
test_str = ("## Should Pass\n\n"
"build: test\n\n"
"chore(topic): descriptoin\n"
"chore(junk): that's better\n"
"¯\\_(ツ)_/¯: descriptoin\n"
"feat: some with-hyphen\n\n\n"
"### should pass with breaking change\n"
"feat!: monkeys are the best for animal testing\n"
"build(three)!: test\n\n\n"
"Merge words\n\n"
"### Failed to match test\n\n"
"Merge\n"
"monkey(dog): no\n"
"junk\n\n"
"### Partials that should fail\n"
"build(with colon): must include colon. <<< fails number four\n"
"build(one) <<< must have descriptoin and must have colon\n"
"feat!:dogs are better for animal testing << give me your whitespace\n\n"
"build <<< thould fail, not allowed end of line\n"
"build(: <<< should fail \n"
"build(words):noSPace <<< should fail\n"
"build(two)asdfadfadasdf_this is a failure\n"
"build(<> : dda!sd): test <<< should this fail? \n"
"build(example:module)!: test subject <<< that should fail too\n"
"¯\\_(ツ)_/¯[type]:descriptoin\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.