#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<type>build|chore|ci|docs|feat|fix|perf|refactor|revert|style|test|¯\\_\(ツ\)_\/¯)(?<scope>\(\w+\)?((?=:\s)|(?=!:\s)))?(?<breaking>!)?(?<subject>:\s.*)?|^(?<merge>Merge \w+)"
Local $sString = "## Should Pass" & @CRLF & _
"" & @CRLF & _
"build: test" & @CRLF & _
"" & @CRLF & _
"chore(topic): descriptoin" & @CRLF & _
"chore(junk): that's better" & @CRLF & _
"¯\_(ツ)_/¯: descriptoin" & @CRLF & _
"feat: some with-hyphen" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"### should pass with breaking change" & @CRLF & _
"feat!: monkeys are the best for animal testing" & @CRLF & _
"build(three)!: test" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Merge words" & @CRLF & _
"" & @CRLF & _
"### Failed to match test" & @CRLF & _
"" & @CRLF & _
"Merge" & @CRLF & _
"monkey(dog): no" & @CRLF & _
"junk" & @CRLF & _
"" & @CRLF & _
"### Partials that should fail" & @CRLF & _
"build(with colon): must include colon. <<< fails number four" & @CRLF & _
"build(one) <<< must have descriptoin and must have colon" & @CRLF & _
"feat!:dogs are better for animal testing << give me your whitespace" & @CRLF & _
"" & @CRLF & _
"build <<< thould fail, not allowed end of line" & @CRLF & _
"build(: <<< should fail " & @CRLF & _
"build(words):noSPace <<< should fail" & @CRLF & _
"build(two)asdfadfadasdf_this is a failure" & @CRLF & _
"build(<> : dda!sd): test <<< should this fail? " & @CRLF & _
"build(example:module)!: test subject <<< that should fail too" & @CRLF & _
"¯\_(ツ)_/¯[type]:descriptoin" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")