$re = '/^[+-]?\d*\.?\d+?$/m';
$str = '342
213.41
.89
+123.321
12034.4231
+3.4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);