package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[+-]?\d*\.?\d+?$`)
var str = `342
213.41
.89
+123.321
12034.4231
+3.4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}