const regex = /([0-2][0-9]|3[0-1])\-(0[1-9]|1[0-2])\-\d{4}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([0-2][0-9]|3[0-1])\\-(0[1-9]|1[0-2])\\-\\d{4}', '')
const str = `31-12-1999
31-13-1999
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}