using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-2][0-9]|3[0-1])\-(0[1-9]|1[0-2])\-\d{4}";
string input = @"31-12-1999
31-13-1999
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}