# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.+? ?, ?(A[LKSZRAP]|C[AOT]|D[EC]|F[LM]|G[AU]|HI|I[ADL N]|K[SY]|LA|M[ADEHINOPST]|N[CDEHJMVY]|O[HKR]|P[ARW]|RI|S[CD] |T[NX]|UT|V[AIT]|W[AIVY])$//i;t' <<< "los angeles, ca"