$re = '/(\b(?\'first_word\'[a-z](?!([[:alnum:]]*_)(?# the word doesn\'t contain underscores))(?:[a-z0-9]*)))|(\G(?\'trailing_word\'[A-Z][a-z0-9]*))/m';
$str = 'camelCase
camel
camelCaseCase
camel684Case
ca45melCase
camelCase6523Case
camelCaseCaseCaseCaseCase
camelCCase
PascalCase
// some random commentary with Capitalized letters
camel_Snake_Case
';
$subst = "\L${first_word}${trailing_word:+_\L${trailing_word}:}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;