$re = '/\d{2}\.\d/';
$str = 'Die Temperaturen betrugen am Montag 22.5 °C und am Dienstag 24.5 °C';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);