package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d{2}\.\d`)
var str = `Die Temperaturen betrugen am Montag 22.5 °C und am Dienstag 24.5 °C`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}