re = /^[a-fA-F\d]{8}(?:\-[a-fA-F\d]{4}){3}\-[a-fA-F\d]{12}$/
str = 'f4917667-1e36-4f67-a018-32b7790e888c'
# Print the match result
str.match(re) do |match|
puts match.to_s
end