package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[a-fA-F\d]{8}(?:\-[a-fA-F\d]{4}){3}\-[a-fA-F\d]{12}$`)
var str = `f4917667-1e36-4f67-a018-32b7790e888c`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}