re = /(.*(?<!(was))\s*)(1[0-7](\sy\.o\.|\syo|(\syears|\syrs|\syrs)\sold))\s*(?!((grand)*daughter|(grand)*son))/m
str = '10 years old'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end