using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*(?<!(was))\s*)(1[0-7](\sy\.o\.|\syo|(\syears|\syrs|\syrs)\sold))\s*(?!((grand)*daughter|(grand)*son))";
string input = @"10 years old";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}