re = /[0-9A-Fa-f]{8}[-]([0-9A-Fa-f]{4}[-]){3}[0-9A-Fa-f]{12}/
str = 'cfc4a2fe-f968-4ef8-b685-e73d1b77271a'
# Print the match result
str.match(re) do |match|
puts match.to_s
end