package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[0-9A-Fa-f]{8}[-]([0-9A-Fa-f]{4}[-]){3}[0-9A-Fa-f]{12}`)
var str = `cfc4a2fe-f968-4ef8-b685-e73d1b77271a`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}