$re = '/^\s*(\w{2,})\s*(\w{2,})\w*|\s*$/m';
$str = 'Mark Full
Mark Full
Mark Full dsad
Mark
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);