const regex = /^\s*(\w{2,})\s*(\w{2,})\w*|\s*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*(\\w{2,})\\s*(\\w{2,})\\w*|\\s*$', 'gm')
const str = `Mark Full
Mark Full
Mark Full dsad
Mark
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}