$re = '/^((?i)REQ[0-9]{1,10};)+((?i)REQ[0-9]{1,10};?)$|^((?i)REQ[0-9]{1,10};)$/m';
$str = 'REQ2;rEq1;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);