package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((?i)REQ[0-9]{1,10};)+((?i)REQ[0-9]{1,10};?)$|^((?i)REQ[0-9]{1,10};)$`)
var str = `REQ2;rEq1;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}