import Foundation
let pattern = #"class="[^"]*(?<="|\s)left-top-container(?="|\s)[^"]*"[^<]*<h2[^>]*>(?<title>[^<]*)</h2"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive, .dotMatchesLineSeparators])
let testString = #"<div class="left-top-container"> <h2 itemprop="name"> Nike Magista</h2> <div class="listing_info"> <div class="list_id"><strong>List-ID: </strong>52002304 </div> <div class="list_time"> Yesterday 09:20 </div> </div> <div class="ad_images"> <!-- IMAGE GALLERY --> <div class="" id="image-gallery"> <div id="gallery-image-border"> <meta itemprop="image" content="http://img.rnudah.com/images/04/044707022491864.jpg"> <span class="trackable favourite-heart favourite-heart-empty" aria-hidden="true" data-list-id="52002304" data-company-ad="0" data-category="4160" data-region="7" data-event_type="view" data-event_name="save_favourite_ad" data-page_name="Add Favourite Ad" data-xtn2="5" data-xiti_f1="4160" data-xiti_f2="7" data-xiti_f3="2" data-xiti_f4="2" data-xiti_f5="248"></span> <div class="heart-icon-tip adview-tip"> <div class="arrow-tip"></div> <div class="tip-content"> Click on the heart to add this to your Favourite list. </div> </div> <div id="gallery-image-container"><span><a href="javascript:void(0)" onclick="gallery.nextImage()"><img src="http://img.rnudah.com/images/04/044707022491864.jpg" style="margin-top:44px;margin-left:0px"></a></span></div> </div> </div> <div id="gallery-thumbnail-containers" style="display: none"> <ul id="gallery-thumbnail-items"> <li><a href="javascript:void(0)" onclick="gallery.move('prev')" class="gallery-navigation" style="display: none;"><img src="/img/none.gif" class="sprite_view_arrow-left"></a></li> <li id="gallery-thumbnails-li"> <div id="gallery-thumbnails-ul-container"> <ul id="gallery-thumbnails" style="width: 540px;"><li data-sort="1" class="thumbnail-active"><a href="javascript:void(0)" style="margin-top: 5.5px" onmouseover="gallery.changeGalleryImage("0")"><img src="http://img.rnudah.com/thumbs/04/044707022491864.jpg"></a></li></ul> </div> </li> <li><a href="javascript:void(0)" onclick="gallery.move('next')" class="gallery-navigation" style="display: none;"><img src="/img/none.gif" class="sprite_view_arrow-right"></a></li> </ul> </div> <!-- IMAGE GALLERY --> </div> <div class="ad_info"> </div></div>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)