const regex = new RegExp('class="[^"]*(?<="|\\s)left-top-container(?="|\\s)[^"]*"[^<]*<h2[^>]*>(?<title>[^<]*)</h2', 'gmis')
const str = `<div class="left-top-container"> <h2 itemprop="name"> Nike Magista</h2> <div class="listing_info"> <div class="list_id"><strong>List-ID: </strong>52002304 </div> <div class="list_time"> Yesterday 09:20 </div> </div> <div class="ad_images"> <!-- IMAGE GALLERY --> <div class="" id="image-gallery"> <div id="gallery-image-border"> <meta itemprop="image" content="http://img.rnudah.com/images/04/044707022491864.jpg"> <span class="trackable favourite-heart favourite-heart-empty" aria-hidden="true" data-list-id="52002304" data-company-ad="0" data-category="4160" data-region="7" data-event_type="view" data-event_name="save_favourite_ad" data-page_name="Add Favourite Ad" data-xtn2="5" data-xiti_f1="4160" data-xiti_f2="7" data-xiti_f3="2" data-xiti_f4="2" data-xiti_f5="248"></span> <div class="heart-icon-tip adview-tip"> <div class="arrow-tip"></div> <div class="tip-content"> Click on the heart to add this to your Favourite list. </div> </div> <div id="gallery-image-container"><span><a href="javascript:void(0)" onclick="gallery.nextImage()"><img src="http://img.rnudah.com/images/04/044707022491864.jpg" style="margin-top:44px;margin-left:0px"></a></span></div> </div> </div> <div id="gallery-thumbnail-containers" style="display: none"> <ul id="gallery-thumbnail-items"> <li><a href="javascript:void(0)" onclick="gallery.move('prev')" class="gallery-navigation" style="display: none;"><img src="/img/none.gif" class="sprite_view_arrow-left"></a></li> <li id="gallery-thumbnails-li"> <div id="gallery-thumbnails-ul-container"> <ul id="gallery-thumbnails" style="width: 540px;"><li data-sort="1" class="thumbnail-active"><a href="javascript:void(0)" style="margin-top: 5.5px" onmouseover="gallery.changeGalleryImage("0")"><img src="http://img.rnudah.com/thumbs/04/044707022491864.jpg"></a></li></ul> </div> </li> <li><a href="javascript:void(0)" onclick="gallery.move('next')" class="gallery-navigation" style="display: none;"><img src="/img/none.gif" class="sprite_view_arrow-right"></a></li> </ul> </div> <!-- IMAGE GALLERY --> </div> <div class="ad_info"> </div></div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}