re = /^(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)(?:\.(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)){3}$/m
str = '137.255.156.100'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end