package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)(?:\.(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)){3}$`)
var str = `137.255.156.100`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}