re = /(?<=<[^>]*)(?<=\s)(on\w+|formaction|action)=["']?(.*?)["']?(?=[\n>])/m
str = '<img src="/name">
<a href="javascript:void">some url</a>
<a href="https://convertkit.com">URL</a>
<img src=x onerror="alert(document.domain)">
<img src=x onerror=" alert(document.domain) ">
<img src=x
onerror="alert(document.domain)"
>
<img src=x onerror=alert(document.domain)>
<button form="form1" formaction="javascript:alert(1)">Submit</button>
<form action=""></form>
<button onclick="hacked()">Hack</button>
<a href="https://convertkit.com/about?utm_content=bazard">click men</a>
<div>onmouseover=alert(1)</div>
<div> onmouseover=alert(1) </div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end