import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=<[^>]*)(?<=\\s)(on\\w+|formaction|action)=[\"']?(.*?)[\"']?(?=[\\n>])";
final String string = "<img src=\"/name\">\n"
+ "<a href=\"javascript:void\">some url</a>\n"
+ "<a href=\"https://convertkit.com\">URL</a>\n"
+ "<img src=x onerror=\"alert(document.domain)\">\n"
+ "<img src=x onerror=\" alert(document.domain) \">\n"
+ "<img src=x\n"
+ "onerror=\"alert(document.domain)\"\n"
+ ">\n"
+ "<img src=x onerror=alert(document.domain)>\n"
+ "<button form=\"form1\" formaction=\"javascript:alert(1)\">Submit</button>\n"
+ "<form action=\"\"></form>\n"
+ "<button onclick=\"hacked()\">Hack</button>\n"
+ "<a href=\"https://convertkit.com/about?utm_content=bazard\">click men</a>\n"
+ "<div>onmouseover=alert(1)</div>\n"
+ "<div> onmouseover=alert(1) </div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}