const regex = /(Loi|Décret)\s+n°\s*(\d\d(?:\d\d)?\-\d{1,4})\s+du\s+([1-9][0-9]?)\s+(janvier|février|mars|avril|mai|juin|juillet|août|septembre|octobre|novembre|décembre)\s+(\d\d\d\d)\s+(.*)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(Loi|Décret)\\s+n°\\s*(\\d\\d(?:\\d\\d)?\\-\\d{1,4})\\s+du\\s+([1-9][0-9]?)\\s+(janvier|février|mars|avril|mai|juin|juillet|août|septembre|octobre|novembre|décembre)\\s+(\\d\\d\\d\\d)\\s+(.*)', 'gi')
const str = `LOI n° 2014-896 du 15 août 2014 relative à l'individualisation des peines et renforçant l'efficacité des sanctions pénales (1)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}