re = /\b[A-Za-z0-9._%+-]+@[A-Za-z0-9.-]+\.[A-Za-z]{2,6}\b/
str = 'hendarmawan@gmail.com
masamir@gmail.com
masamir@gmail.com.au
masamir@gmail.com.au.us
masamir@gmail.com.au.us.us
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end