package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b[A-Za-z0-9._%+-]+@[A-Za-z0-9.-]+\.[A-Za-z]{2,6}\b`)
var str = `hendarmawan@gmail.com
masamir@gmail.com
masamir@gmail.com.au
masamir@gmail.com.au.us
masamir@gmail.com.au.us.us
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}