re = /^([ABCEGHJKLMNPRSTVXY][0-9][A-Z][ ]*[0-9][A-Z][0-9])$/m
str = 'M4B 1T4
m4b 1t4
M4B1T4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end