package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([ABCEGHJKLMNPRSTVXY][0-9][A-Z][ ]*[0-9][A-Z][0-9])$`)
var str = `M4B 1T4
m4b 1t4
M4B1T4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}