$re = '/^.*?\.\d{1,2}/m';
$str = '1111.000.000
33.2
4422200.02.20
1111.3.12345678910';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);