package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*?\.\d{1,2}`)
var str = `1111.000.000
33.2
4422200.02.20
1111.3.12345678910`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}