re = /^(redbook|bluepen|yellowglass)\s(greenapple|pinkglass)$/m
str = 'greenapple redbook '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end