package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(redbook|bluepen|yellowglass)\s(greenapple|pinkglass)$`)
var str = `greenapple redbook `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}