$re = '/^(小|初|高|职)(\d{4})级$/m';
$str = '小2020级';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);