package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(小|初|高|职)(\d{4})级$`)
var str = `小2020级`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}