const regex = /((([0-9]*\.[0-9]+)|([0-9]+\.[0-9]*))(E(\+|-)?[0-9]+)?)|([0-9]+(E(\+|-)?[0-9]+))/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((([0-9]*\\.[0-9]+)|([0-9]+\\.[0-9]*))(E(\\+|-)?[0-9]+)?)|([0-9]+(E(\\+|-)?[0-9]+))', 'm')
const str = `1.123
1.E123
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}