import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^!]\\[.+?\\]\\(.+?\\)";
final String string = "Find a [bad link](http://www.google.com) that\n"
+ "[is not](http://www.yahoo.com) an image ![image alt](../images/me.jpg)\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}