package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^!]\[.+?\]\(.+?\)`)
var str = `Find a [bad link](http://www.google.com) that
[is not](http://www.yahoo.com) an image ![image alt](../images/me.jpg)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}