use strict;
my $str = '
http://example.com/u/adadad.html
sdfsf http://example.com/v/adadad.html';
my $regex = qr/(?:^[ \t]{0,50}\r?\n){3}[ \t]{0,10}(http:\/\/(?!www\.)[^\s\/]{3,30})\/([ucv])\/([^\s\.]{3,60}\.html?)\S{0,10}[ \t]{0,10}\r?\n(?:^[ \t]{0,50}\r?\n){5,50}[^\/]{1,100}\b\1\/(?!\2)[ucv]\/\3/imp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}