#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(?:^[ \t]{0,50}\r?\n){3}[ \t]{0,10}(http:\/\/(?!www\.)[^\s\/]{3,30})\/([ucv])\/([^\s\.]{3,60}\.html?)\S{0,10}[ \t]{0,10}\r?\n(?:^[ \t]{0,50}\r?\n){5,50}[^\/]{1,100}\b\1\/(?!\2)[ucv]\/\3"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"http://example.com/u/adadad.html" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"sdfsf http://example.com/v/adadad.html"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")