$re = '/<script.*?>.*?<\/script>/im';
$str = '<\'<script></script>script type="text/javascript">al<script></script>ert("test");<\'<script></script>/script> ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);