package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)<script.*?>.*?<\/script>`)
var str = `<'<script></script>script type="text/javascript">al<script></script>ert("test");<'<script></script>/script> `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}