import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "PC\\D*((([\\dA-Z]{5})-){4}\\g<3>)";
final String string = "PC: WW533-S5T3B-53JJB-JTBT3-WZRBH\n"
+ "PS3: WW533-S5T3C-39JKB-STCT3-WZRRS\n"
+ "XBOX: WW533-S5T6F-65RJF-KXBT3-WZRW9\n\n"
+ "PC: CCCBB-X5JTB-5BB33-TJ3BJ-SK3KR\n"
+ "PS3: CCCBB-X5JTC-3HB53-ZJ5BJ-SK3ST\n"
+ "XBOX: CCCBB-X5JXF-6CF36-WR3BJ-SK3XW\n\n"
+ "PC: 5CKBB-K53BJ-CJTTT-JTJ3B-BHCSJ\n"
+ "PS3: 5CKBB-K53BK-BSTWT-STK3B-BHCTZ\n"
+ "XBOX: 5CKBB-K53FR-FKXTX-KXJ3B-BHCFW\n"
+ "PC: 5WWBJ-TWBJJ-KT3JB-TJBBB-CJ5KJ\n"
+ "PS3: 5WWBJ-TWBJK-JZ3KB-ZJCBB-CJ555\n"
+ "XBOX: 5WWBJ-TWBRR-RW6JF-WRBBB-CJ5T9\n"
+ "BL: TPS 1 GK: PS3: WCWBT-S3TTK-BSJK3-HT5TB-TWR9W WinPC/Mac/Linux: WCWBT-S3TTJ-CJJJ3-BT3TB-TWRWZ X360: WCWBT-S3TXR-FKRJ6-CX3TB-TWR3R\n\n"
+ "BL: TPS 1 GK: PS3: C5KTB-RTJ35-B93WT-HBKBB-WZWBX WinPC/Mac/Linux: C5KTB-RTJ33-C33TT-BBJBB-WZWJX X360: C5KTB-RTJ66-F56TX-CFJBB-WZWX5\n\n"
+ "BL: TPS 1 GK: PS3: C5CJB-WTT3W-TSJCT-ST5JJ-CKJKX WinPC/Mac/Linux: C5CJB-WTT3T-WJJBT-JT3JJ-CKJZ3 X360: C5CJB-WTT6X-XKRBX-KX3JJ-CKJZX\n\n"
+ "Nov 13\n"
+ "The Pre-Sequel:\n"
+ "PS3: C5CTT-3JJJK-B9JWJ-S35BJ-SZ99H WinPC/Mac/Linux: C5CTT-3JJJJ-C3JTJ-J33BJ-SZ9SK X360: C5CTT-3JJRR-F5RTR-K63BJ-SZ9KW\n\n"
+ "BL:TPS GK:\n"
+ "PS3: WW533-S5T3C-39JKB-STCT3-WZRRS\n"
+ "WinPC/Mac/Linux: WW533-S5T3B-53JJB-JTBT3-WZRBH\n"
+ "X360: WW533-S5T6F-65RJF-KXBT3-WZRW9";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}