#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "PC\D*((([\dA-Z]{5})-){4}\g<3>)"
Local $sString = "PC: WW533-S5T3B-53JJB-JTBT3-WZRBH" & @CRLF & _
"PS3: WW533-S5T3C-39JKB-STCT3-WZRRS" & @CRLF & _
"XBOX: WW533-S5T6F-65RJF-KXBT3-WZRW9" & @CRLF & _
"" & @CRLF & _
"PC: CCCBB-X5JTB-5BB33-TJ3BJ-SK3KR" & @CRLF & _
"PS3: CCCBB-X5JTC-3HB53-ZJ5BJ-SK3ST" & @CRLF & _
"XBOX: CCCBB-X5JXF-6CF36-WR3BJ-SK3XW" & @CRLF & _
"" & @CRLF & _
"PC: 5CKBB-K53BJ-CJTTT-JTJ3B-BHCSJ" & @CRLF & _
"PS3: 5CKBB-K53BK-BSTWT-STK3B-BHCTZ" & @CRLF & _
"XBOX: 5CKBB-K53FR-FKXTX-KXJ3B-BHCFW" & @CRLF & _
"PC: 5WWBJ-TWBJJ-KT3JB-TJBBB-CJ5KJ" & @CRLF & _
"PS3: 5WWBJ-TWBJK-JZ3KB-ZJCBB-CJ555" & @CRLF & _
"XBOX: 5WWBJ-TWBRR-RW6JF-WRBBB-CJ5T9" & @CRLF & _
"BL: TPS 1 GK: PS3: WCWBT-S3TTK-BSJK3-HT5TB-TWR9W WinPC/Mac/Linux: WCWBT-S3TTJ-CJJJ3-BT3TB-TWRWZ X360: WCWBT-S3TXR-FKRJ6-CX3TB-TWR3R" & @CRLF & _
"" & @CRLF & _
"BL: TPS 1 GK: PS3: C5KTB-RTJ35-B93WT-HBKBB-WZWBX WinPC/Mac/Linux: C5KTB-RTJ33-C33TT-BBJBB-WZWJX X360: C5KTB-RTJ66-F56TX-CFJBB-WZWX5" & @CRLF & _
"" & @CRLF & _
"BL: TPS 1 GK: PS3: C5CJB-WTT3W-TSJCT-ST5JJ-CKJKX WinPC/Mac/Linux: C5CJB-WTT3T-WJJBT-JT3JJ-CKJZ3 X360: C5CJB-WTT6X-XKRBX-KX3JJ-CKJZX" & @CRLF & _
"" & @CRLF & _
"Nov 13" & @CRLF & _
"The Pre-Sequel:" & @CRLF & _
"PS3: C5CTT-3JJJK-B9JWJ-S35BJ-SZ99H WinPC/Mac/Linux: C5CTT-3JJJJ-C3JTJ-J33BJ-SZ9SK X360: C5CTT-3JJRR-F5RTR-K63BJ-SZ9KW" & @CRLF & _
"" & @CRLF & _
"BL:TPS GK:" & @CRLF & _
"PS3: WW533-S5T3C-39JKB-STCT3-WZRRS" & @CRLF & _
"WinPC/Mac/Linux: WW533-S5T3B-53JJB-JTBT3-WZRBH" & @CRLF & _
"X360: WW533-S5T6F-65RJF-KXBT3-WZRW9"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")